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Intellectual Property Rights
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1 Preface
1.1 About this Document

This application note is intended to provide a description about how diagnostic events are pre-
sented in the engineering tool for the industrial network Modbus-TCP.

It is divided into two parts:

Part one provides a short overview of the Anybus CompactCom 40 Diagnostic Object (02h) and
its diagnostic events. Part two is an example, showing how to get diagnostic messages dis-
played for Modbus-TCP using the PLC engineering tool Unity Pro XLV8.0.

1.1.1 Target Audience
This document is meant for trained and skilled personnel working with the equipment described.

You need electrical engineering skills for the installation and commissioning of electrical
equipment.

You also need general knowledge of automation and programmable logic controllers, in particu-
lar about the Schneider automation software Unity Pro XL. Additionally knowledge on the Mod-
bus-TCP Industrial Ethernet protocol and the Anybus CompactCom (ABCC) object model is
necessary.

1.2 History
Revision Date Description Responsible
1.0 2016-10-17 First version OLB
1.1 2017-02-09 Converted to DOX KaD

1.3 Referenced Documents
Description Name / Type Version
HMS Starter Kit HMS Development Board 2

Rev 1.07
0314-1.1.1

Anybus CompactCom 40
module

ABCC-M40-EIT V.1.06

Schneider Electric Modicon
M340 Station Components

CPU: BMX P34 20302
CM: BMX NOC 0401.2

SV: 2.40
SV: 2.10

Anybus CompactCom 40
Modbus-TCP

Network Guide V1.10

Anybus CompactCom Soft-
ware Design guide

Software Guide V3.0

PC with Schneider PLC pro-
gramming software

Unity Pro XL V8.0 - 131118

IDE KEIL uVision 5 V5.20
Anybus CompactCom Driver Anybus CompactCom Host Application Ex-

ample Code
V2.01

1.4 More Information about Networks and Products
The latest manuals and EDS files can be found on the HMS website, www.anybus.com
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1.5 Trademark Information
Anybus® is a registered trademark of HMS Industrial Networks AB.

All other trademarks are the property of their respective holders.
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2 Introduction
The ability of an automation device to raise diagnostic events is an important benefit. It may not
only reflect a higher level of quality setting it apart from competitors in the market, in the end it
will also increase the device’s reliability, reduce downtimes by relieving preventive maintenance
and protect the investment.

Implementing this feature set allows the device to signal significant incidents towards the PLC.
This way operators will immediately be informed in case the device experiences errors or faults.

This document describes how developers of a field device implementing an Anybus Compact-
Com 40 Modbus-TCP network interface can use its features to create diagnostics events.
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3 The Diagnostic Object
The Anybus CompactCom concept is based on an object model.

For detailed information about this, please refer to the Anybus CompactCom 40 Software De-
sign Guide.

For creating diagnostics (information from a field device to a PLC) the CompactCom concept
contains the diagnostic object (02h) which is located inside the CompactCom. A diagnostic
event is created by sending a create (03h) command to the diagnostic object (02h) of the
CompactCom.

3.1 Create a Diagnostic Event
When the CompactCom device has been started and initialized, the diagnostic object (02h) is
solely built up of its object instance #0 containing attributes common to all subsequent instan-
ces which may be added in the course of the device’s operation. The process of reporting a di-
agnostic event to the network is initiated by the host application. To this end a create (03h)
event command message is sent from the host application to the diagnostic object (02h).

The CompactCom will internally create a new instance inside the diagnostic object (02h). This
new instance corresponds to a diagnostic event.

The create (03h) command must contain information for describing the diagnostic event: a Se-
verity (CMDExt[0]) and an Event Code (CMDExt[1]). The severity indicates how critical the
event is and if it will recover by itself or not. CMDExt[0] additionally contains a bit called Ex-
tended Diagnostic, which informs the CompactCom if the event message contains additional
user specific data. If the Extended Diagnostic bit is set, the additional user specific data will be
found in MsgData[8..n], and the standard data in MsgData[0..7].

An Event Code informs about the nature of the event, i. e. what caused the device to react, like
exceeding temperature or current limit.
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3.2 Severity Codes of Diagnostic Events
The following severity codes are defined for the CompactCom:

Typically, recoverable events are generated by the process e.g. if a temperature exceeds a limit
value defined by the device manufacturer (e.g. internal temperature of the device exceeds 50°
C). The character of this event is typically a warning when the event is defined as minor. The
temperature of the device is recoverable as the device can cool down again when some heat
producers are cut off.

The device manufacturer will add amajor recoverable event when he wants to inform the PLC
that the temperature has reached a critical high temperature which can damage the device.

An unrecoverable diagnostic event is typically created when the device detects that a sensor
is broken. The sensor has to be replaced, it will - normally – not recover by itself. If the device
has only one sensor and this sensor is broken the device will create amajor unrecoverable
event. The device has to be stopped and to be repaired (replace the broken sensor) before
used again otherwise there will be a big risk that the device will be damaged after restart. If the
device has some redundant sensors it will create aminor unrecoverable event informing the
users that the broken sensor should be replaced by another one within the next scheduled
inspection.

Minor latching andmajor latching allow the creation of latching diagnostic event.

In Modbus-TCP, latching events are not supported.

For more information, see the Software Design Guide and the Network Guide of the Anybus
CompactCom 40 device.

The device manufacturer has to define which event will be reported as a diagnostic
event to the PLC and which severity has to be used.
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3.3 Anybus CompactCom Event Codes
The table below shows a list of the event codes applicable for Anybus CompactCom 40 device.

The event code FFh is used if network specific diagnostics are reported (not considered within
this application note).
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4 Modbus-TCP Diagnostics
To show the commissioning within the Schneider Modicon environment, we will be using the
Unity Pro XL engineering tool and start with a blank project. In step one, we will configure the
PLC, and in step two the Modbus TCP network and its devices.

4.1 PLC Configuration

Start a Unity Pro XL project by clicking on menu File > New. From the Modicon M340 series of
PLCs, select the BMX P34 20302 together with its corresponding rack, in our case an 8 slot
backplane as shown in the picture below.

Press OK and right-click on “PLC bus” in the navigation list to the left and select Open. This will
open a new window showing the rack with its power supply, the CPU and 7 empty slots.
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Now add a new communication module to the project by double-clicking on slot 1. This will open
a window where you can select the communication module you want to use. In our case, we
choose the Ethernet module BMX NOC 0401 from the list.

Press OK and the new device will be added as shown in the picture below.
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At this stage it is possible to set the IP address of the PLC, which will be taken into effect once
the configuration has been downloaded into the PLC. To do this in the project browser, expand
the Communication folder then right-click on Networks and select New Network.

Select Ethernet and choose a name. In our case the network is named “modbus”. Click OK.
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The red X symbol next to the network name means that the network is not linked to an Ethernet
port.

Double-click or right-click on modbus and select Open. The picture below will appear

Anybus CompactCom 40 Diagnostic Events for Modbus-TCP SCM-1202–039 1.1



Modbus-TCP Diagnostics 14 (28)

Change the model family to cpu 2020, cpu 2030 (>= V02,00), PRA 0100. Click on Yes.

Enter the IPAddress, Subnetwork mask and Gateway address (if needed) as shown in the pic-
ture above. Validate your settings in menu Edit > Validate.

In the next step, expand the “PLC bus” in the configuration folder and the CPU named BMX
P34 20302. Double-click on Ethernet and configure the network the PLC module is to be con-
nected to.

Open the configuration in the left navigation list and double-click on the Ethernet interface of the
CPU.

The window below will be opened. In the window to the right of the navigation list, select chan-
nel 3 under Function ETH TCP IP andmodbus under Net link. Validate the changes by clicking
on the black check mark in the project toolbar or in menu Edit > Validate.

The connection will be established.

Now you can download your configuration to the PLC. To do this link the PLC to the Unity Pro
software through USB (cable), Ethernet, or Modbus.
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In the menu PLC select Set Address. The following screen appears:

In media menu, select USB, as shown in the above figure. Press OK.

On the Unity Pro XL tab, select PLC > Connect to link the M340 system. Open the transfer proj-
ect to PLC by selecting PLC > Transfer Project to PLC

After that, disconnect the PLC by clicking PLC > Disconnect. Set the IP address at PLC > Set
Address in menu media, select TCPIP and enter the IP address you have configured earlier
and then press OK.
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4.2 Modbus-TCP Network Configuration
The communication module (BMX NOC401.2) is configured via the DTM browser. DTM stands
for device type manager, to integrate remote devices, in this case Anybus CompactCom 40
Modbus TCP. The Anybus CompactCom 40 module will be added to the hardware catalog by
means of a DTM.

Adding a device to the configuration means adding the DTM device to the Unity Pro’s DTM
browser. To do this, open the DTM browser by clicking on the menu Tools and select DTM
browser.
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In the DTM browser, select the communication module in order to add the modbus device. Right
click on BMX NOC401.2 then select Add . The picture below will appear.

Select Modbus Device (1) then Press Add DTM (2) as shown above.
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Click OK.

Double-click on the communication module ( <192.168.0.1> M_NOC0401.2). A window to the
right of the navigation list will be opened. Set up the IP address of your host PC under Channel
properties as shown above.
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In TCP/IP set the configuration to static. Change the IP address of the communication module
M_NOC0401. In our case, set the IP address to 192.168.1.1.

Then under Device List, select your modbus device. In the tab Address Setting, change the
IP address corresponding to the IP address of the Anybus CompactCom Modbus-TCP module.

Move to the next tab Request Setting and click on Add Request. Default values will be filled
out in the first row.

Then, set the new length of the I/O data in RD length andWR length .

RD address indicates the address of the PLC memory where from each device the information
is read and stored andWR address indicates the address of PLC memory from where data is
written into the slave device.

As example, set RD length to 32 words andWR length to 32 words as shown above… and
click on apply.
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Click on Request 001: Items. The elements are applied to the PLC as bytes, but the presenta-
tion of the data can be modified depending on how you want to access the data (e.g. as 16-bit
registers).

In this example the first eight elements are presented as words at the outputs, leaving the rest
as bytes.

To do this, select, with the mouse, the number of bytes you want to present as words then click
on Define Item(s). We can do the same for inputs. Confirm by clicking on apply.

Configure I/O word range of BMX NOC 0401.2. In the Project browser window double-click on
BMX NOC 0401.2, then select the configuration tab. Type in the starting address and maximum
number of 16 bits words dedicated for inputs/outputs as shown below. Validate the settings by
clicking on the black check mark.
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Before you build your project, the CANopen inputs/outputs values should be set to zero as de-
scribed in the following picture. Then validated, built and saved.

Download your project to the PLC. Set up the standard mode in the PLC menu. Then select
transfer project to the PLC and click on transfer to finish the operation. In the menu toolbar, click
on the Run icon.

The process data exchange can start between the PLC and the Anybus CompactCom device.

Select the DTM you want to connect to remote device (in this case, the CompactCom Modbus-
TCP device). Click the right mouse button and select Connect. If the device name appears in
bold text it is connected as shown below.
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4.3 Diagnostics in Modbus-TCP
This section shows how Modbus-TCP handles diagnostic data.

Modbus-TCP provides only one way for reporting diagnosis messages. This is done through
the acyclic data channel.

In the Modbus protocol, function codes are used to access data. They determine whether data
is to be read or written, and what kind of data is involved. The table above shows public function
codes that give access to 16 bit registers.

The Modbus function code dedicated to diagnosis is 08. It is applicable only for serial line
devices.

Therefore, the Anybus CompactCom 40 Modbus-TCP is devised to use function code 04 to
read out specific Input Registers dedicated to diagnostics events.

Extended diagnostic information is not supported by the Anybus CompactCom 40 Modbus-TCP
since network specific information is not implemented.
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5 Application Example
In this example, we are using the Anybus CompactCom 40 Starter Kit in which we integrate the
Anybus CompactCom 40 device. We use the host application example code for the windows
platform to simulate the host application. We also run the automation engineering tool Unity Pro
XL by Schneider, for configuring the PLC. In this example, we employ Modicon 340 with -CPU
BMX P34 20302- used as PLC-controller and -BMX NOC 0401.2- used as communication mod-
ule. The engineering tool will also report the diagnostic events sent by the CompactCom device
to the PLC.

The following section will explain what has to be done from the application side to make the
Anybus CompactCom 40 Modbus-TCP device send field device diagnosis to the network
master.
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5.1 Sample for Creating a Diagnostic Event
This sample is intended to show how to create a diagnostic event in the CompactCom using the
Anybus CompactCom 40 host application example code. The example below shows the struc-
ture of a create (03h) event command message, that generates a diagnostic event defined as
minor recoverable for the event code temperature.

Section 6.1 will show how this event is displayed on Unity Pro XL.

The create (03h) event command above has created a diagnostic event including the severity
code (minor recoverable (0x00)) and the event code (temperature (0x40)). There is no data
included in the message in this case.

The following section will show the appropriate diagnostic message for each diagnostic event
when a diagnostic event is created and deleted from the Modbus-TCP slave device.
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6 Readout of Diagnostics in Unity Pro XL
This section shows how Unity Pro XL handles diagnostic data.

Start your project in Unity Pro XL with all the settings complete, including your Anybus Com-
pactCom 40 Modbus-TCP device. Since the Modbus protocol only allows acyclic access to
registers for reading diagnostic messages, to be able to read out diagnostic information from a
Modbus-TCP slave device we use the Modbus Explicit Message window. This is done to send
an explicit message from the Unity Pro XL to a Modbus-TCP device -Here the CompactCom 40
Modbus-TCP module.

In the DTM browser, select the communication module and right click. In the dropdown menu,
select Device menu→ Additional functions → Modbus Explicit Message as shown below.

The Modbus Explicit Message window will be opened.

Before performing explicit messaging, connect the DTM for the communication module to the
CompactCom 40 device.

To do this, select the module node in the DTM Browser, then select Edit→ Connect.
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The Modbus-TCP Explicit Message window, below, presents an example of both the configura-
tion of a Modbus-TCP explicit message, and the response. In this example, the explicit mes-
sage is used to read the six input registers in the CompactCom Modbus-TCP device dedicated
for diagnostic events, starting at offset 2049.

To configure the explicit message means, here, to type the IP address of the CompactCom de-
vice, select the function code 04 including the action to perform ReadInputRegisters, set the
number of registers to read to the value 6 and the start address to 2049 (0801h). After the con-
figuration of the explicit message is done, click on Send to Device in the red frame. The diag-
nostic information will be displayed in the response area, in hexadecimal format, in the green
frame.

6.1 Severity: Minor Recoverable and Major Recoverable
The picture below presents two active diagnostic events defined asminor recoverable (00h)
highlighted in yellow and two other active diagnostic events highlighted in red defined as major
recoverable (20h). In this case four input registers are read. Each input register contains 2
bytes. The first byte is the high byte returning the severity code and the second byte is the low
byte associated with the event code.
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6.2 Severity: Minor Unrecoverable
The picture below shows two active diagnostic events defined asminor unrecoverable. From
the response area, two input registers can be read out. Each input register provides the infor-
mation about the severity of the event and the nature of the event. In the first input register the
high byte (0x10) represents the severity code (minor unrecoverable event) and the low byte
(20h, “Current”) the nature of the event which represents the event code. This diagnostic event
cannot be deleted. A reset of the CompactCom device will delete this diagnostic event.

6.3 Severity: Major Unrecoverable
The creation of a major unrecoverable diagnostic event causes the Anybus CompactCom 40
device to enter EXCEPTION state. This results in a disconnection of the device from the net-
work. It is not possible to report any diagnostic. This is confirmed by the picture below.
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